Motorola Atrix 4G Gets ICS Based CM9 ROM [Download & Install]

Advertisement

CyanogenMod 9 for the Atrix 4G hits the internet! The device has kept up nicely with the recent developments with updates and custom ROMs as well as CM7 ROMs, but the arrival of CM9 seems to be the start of bigger things to come for the Atrix 4G. That said, this release is a port and comes to the users courtesy of XDA-Developers forum member jokersax11. The ROM is said to be pretty stable but there are quite a few things broken and missing. The ROM, is after all an Alpha for now.

Stuff like, Camera, HDMI landscape, YouTube, Car dock (missing apk) and Built in video playback are broken for now. There are some issues with 2D rendering and Adobe Flash as well. For a complete list on what is actually working in this ROM, we suggest you check out the forum thread (link provided at the end) because it is a rather long list. So if you wish to give this very Alpha ROM a go on your Atrix 4G, here’s how you can do that.

Disclaimer: Please follow this guide at your own risk. AddictiveTips will not be liable if your device gets damaged or bricked during the process.

Requirements:

Instructions:

  1. To begin, download the zip file and copy it to the root of your SD card.
  2. Reboot the device into recovery and make a Nandroid backup.
  3. Select wipe data/factory reset, wipe cache and wipe dalvik cache.
  4. Navigate to install zip from sdcard > choose zip from sdcard and select the ROM to install it.
  5. Do the same for Google Apps.
  6. Once the files are flashed, simply reboot your device.

For updates and queries, head over to the forum thread at XDA-Developers.

Advertisement
  • Rocky

    Which ROM should I need to download from 6 ROMS listed?? Please help, I need to flash my phone..

    • this is the newest one out alpha5-cm-9.0.0-RC0-Atrix-KANG-signed.zip

  • Mirela Rogoveanu

    y dont hav a wi-fi connection
     

  • Mirela Rogoveanu

    no cam

  • Evan Fossier

    When i tried to wipe data/factory reset it wiped everything except it said error mountain sdcard/.android/secure and skipped it. I installed everything else like normal but now it says no sdcard, i never had a sdcard but used the 16gb of internal storage. regardless it isnt accessible. what do i do? 

  • Tonndorf15

    When I have finished the installation of alpha5 the atrix reboots. But the system doesnt start. There is only the bottscreen (many 4corners (short video)). And its starts again and again…….what is wrong? what can i do?